Opened 14 years ago

Closed 7 years ago

#85 closed defect (wontfix)

Intern strings should parse out body content

Reported by: david Owned by: James Burke
Priority: high Milestone: future
Component: BuildTools Version: 0.0
Keywords: Cc:
Blocked By: Blocking:

Description

The widget system currently parses out <body> content to allow folks to dev widgets in full HTML pages (as some environments require). String interning should also perform this function when creating the package for smaller file sizes and less cruft.

Change History (9)

comment:1 Changed 13 years ago by dylan

Milestone: 0.5
Owner: changed from alex to jkuhnert

comment:2 Changed 13 years ago by jkuhnert

Status: newassigned

This should really be changed to a general task of finding a reasonable way to strip down the filesize of non dojo.js src files when doing a release build.

comment:3 Changed 13 years ago by jkuhnert

Owner: changed from jkuhnert to James Burke
Status: assignednew

I think this is a duplicate of functionality already being covered by jslinker, just re-assigning to see if I'm correct.

comment:4 Changed 12 years ago by James Burke

This is just an optimization, something that existed in 0.4.x too. Not a blocker for 0.9.

comment:5 Changed 12 years ago by James Burke

Milestone: 0.91.0

comment:6 Changed 11 years ago by James Burke

Milestone: 1.02.0

comment:7 Changed 11 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:8 Changed 10 years ago by James Burke

Milestone: 1.3future

comment:9 Changed 7 years ago by dylan

Resolution: wontfix
Status: newclosed

This is a long-lived ticket with no requests to make it happen in 3+ years, so closing. Please re-open if you see a real need for it.

Note: See TracTickets for help on using tickets.