Opened 10 years ago

Closed 10 years ago

#8449 closed defect (invalid)

grid layout problem

Reported by: ben hockey Owned by: Bryan Forbes
Priority: high Milestone: 1.3
Component: DojoX Grid Version: 1.2.3
Keywords: grid layout Cc:
Blocked By: Blocking:

Description

i have a grid in the center region of a border container.

using 1.2.3: with the markup as provided in the attached file, if i resize the window, the grid does not resize properly. if i click on one of the column headings then the grid will fix it's layout. if i remove the h2 tag the grid resizes properly.

using trunk (revision 16388): i have the same resizing problem as described above. also, when the grid is first drawn, the column headings appear to be about double the height that they should be. clicking one of the column headings fixes it and removing the h2 tag also prevents it from happening.

Attachments (1)

gridLayout.html (2.7 KB) - added by ben hockey 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by ben hockey

Attachment: gridLayout.html added

comment:1 Changed 10 years ago by Bryan Forbes

Milestone: tbd1.3

comment:2 Changed 10 years ago by Bryan Forbes

Resolution: invalid
Status: newclosed

This is not a problem with the grid. The problem is that you have the grid in the ContentPane? with content. The way the ContentPane? only sends resize info to child widgets if there is only one widget. If you add another BorderContainer? in there to separate the h2 and grid and surround the h2 with a content pane, it will work fine.

Note: See TracTickets for help on using tickets.