Opened 11 years ago

Closed 7 years ago

#8444 closed defect (wontfix)

dojox.image.SlideShow don't show navigation bar on IE and contains some errors on firefox when attached to dailog

Reported by: Mina R Waheeb Owned by: Shane O'Sullivan
Priority: high Milestone: 1.9
Component: Dojox Version: 1.2.3
Keywords: SlideShow Dialog Cc:
Blocked By: Blocking:

Description

Hi,

I'm trying to attach SlideShow? to Dailog but there is a lot of issues happens:

On IE7: 1 - The gallery size is invalid about without CSS modification 2 - the navigation bar of the SlideShow? never painted but the functionality working fine but there is no image when i click on the image place its navigate correctly. 3 - the image title goes behind the images.

On Firefox: 1 - Everything is working fine expect Firefox report errors _vp and _displaysize is undefined

Test Case <code> var gallery = new dojox.image.SlideShow?({imageHeight:600,imageWidth:600,fixedHeight:true}); gallery.setDataStore(new dojo.data.ItemFileReadStore?({data: { identifier: 'id', label:'title', items: <?=$this->inlineJSON($data)?> items goes here }}), { query: {}, count:20 }); var dailog = new dojox.widget.Dialog({ id: "ProjectsGallaryDailog?", easing:dojo.fx.easing.backOut, sizeDuration:2000, sizeMethod:"combine", dimensions: [618,650], viewportPadding:0, content:gallery.domNode, _displaysize:{w:618,h:680}, Work around for FF3 BUG _vp: dijit.getViewport() Work around for FF3 BUG }); dailog.startup(); dojo.style(gallery.domNode,'width', '600px'); dojo.style(gallery.domNode,'height', '618px'); dojo.connect(dojo.byId("ProjectImage?"), "onclick", function(){ dailog.show(); }); </code>

I'm using lastest trunk version.

The gallery working fine on both IE and FF3 without the Dailog so the issue is related to Dailog. Is there is anything i do wrong? or any work around?

Please verify.

Thanks.

Change History (5)

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to dante

comment:2 Changed 11 years ago by Mina R Waheeb

When using inner HTML declaration everything is working fine on both IE7 and FF3. when using a programmatic declaration the errors still remaining. dialog.layout() helps FF3 to recover the errors but IE7 still lame as always :D

<div id="ProjectsGallaryDailog" dojoType="dojox.widget.Dialog" easing="dojo.fx.easing.backOut" sizeDuration="2000" sizeMethod="combine" dimensions="[618,650]" viewportPadding="0" doLayout="true">
    <div id="ProjectsGallarySlideShow" dojoType="dojox.image.SlideShow" imageWidth="600" imageHeight="600"></div>
</div>
dojo.parser.parse(dojo.byId('ProjectsGallaryDailog'));
dijit.byId('ProjectsGallarySlideShow').setDataStore(new dojo.data.ItemFileReadStore({data: {
    identifier: 'id',
    label:'title',
    items: <?=$this->inlineJSON($data)?>
}}), { query: {}, count:20 });
dojo.connect(dojo.byId("ProjectImage"), "onclick", function(){
    dijit.byId('ProjectsGallaryDailog').show();
});

comment:3 Changed 11 years ago by dante

Milestone: tbdfuture
Owner: changed from dante to SOS

comment:4 Changed 9 years ago by Douglas Hays

Owner: changed from SOS to Shane O'Sullivan

comment:5 Changed 7 years ago by dylan

Milestone: future1.9
Resolution: wontfix
Status: newclosed

SlideShow? widget is no longer actively maintained. Closing as wontfix, though a patch would be considered.

Note: See TracTickets for help on using tickets.