Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8427 closed defect (fixed)

[regression] Menu: menu often has border between label and right arrow (safari, chrome)

Reported by: bill Owned by: liucougar
Priority: high Milestone: 1.3
Component: Dijit Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

On safari, in test_Tree.html, and in the drop down menus from the MenuBar in test_Menu.html, the menu shows a vertical bar between the labels and the arrows.

screen shot

Looks OK on FF.

This started w/[16168] but it's actually due to a bug in safari. Test case from Cougar:

<table style="border:1px solid #7EABCD;border-collapse:collapse;">
            <tbody><tr><td></td><td colspan="2">one</td><td>&nbsp;&nbsp;</td>
</tr></tbody></table>

In order to reproduce this bug, it has to meet the following:

  1. border-collapse is set to collapse
  2. a td with colspan=2
  3. there is a td before the colspan=2 td

Attachments (1)

treeMenu.png (18.1 KB) - added by bill 10 years ago.
screen shot

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by bill

Attachment: treeMenu.png added

screen shot

comment:1 Changed 10 years ago by bill

Description: modified (diff)
Summary: Menu: menu on tree test page has vertical bar (safari)Menu: menu often has border between label and right arrow (safari)

comment:3 Changed 10 years ago by bill

Milestone: tbd1.3
Owner: set to liucougar
Summary: Menu: menu often has border between label and right arrow (safari)[regression] Menu: menu often has border between label and right arrow (safari, chrome)

I don't want to release 1.3 w/this regression (even though it's due to a webkit bug). Can be worked around by:

  1. don't use colspan=2, just always leave column for accelerators
  2. don't use colspan=2 for webkit (note that problem is safari and chrome so the correct check is for webkit)
  3. some clever CSS change to make the problem go away

comment:4 Changed 10 years ago by bill

Priority: normalhigh

comment:5 Changed 10 years ago by liucougar

Resolution: fixed
Status: newclosed

(In [16369]) fixes #8427: a css workaround for this webkit bug: explicitly hiding the right border of the td with colspan=2

comment:6 Changed 10 years ago by liucougar

(In [16396]) refs #8427: oops, quote around 2 is required (I have this line in my local test_Menu.html file, this is the actually working workaround)

Note: See TracTickets for help on using tickets.