Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#8392 closed defect (fixed)

Textarea: problem displaying empty dijit.form.Textarea in Safari

Reported by: ben hockey Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

an empty dijit.form.Textarea does not display properly. it shows a box that is shorter than a box with content and the box does not resize as you add content to it.

in the current test for dijit.form.Textarea (http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Textarea.html) i don't see a test for an empty Textarea. it may be appropriate to add an empty Textarea to this test as well.

this does not happen in 1.2.3 - only in trunk.

Attachments (1)

Textarea.html (951 bytes) - added by ben hockey 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by ben hockey

Attachment: Textarea.html added

comment:1 Changed 11 years ago by bill

I'm not sure what you are getting at. An empty <div> is also shorter than a <div> with content. This is not a bug, but the way that <div>'s and Textarea are designed to work.

Are you saying that it's too short to input any text?

Also, Textarea was redesigned since the 1.2 release. Are you having problems on the trunk code?

comment:2 in reply to:  1 Changed 11 years ago by ben hockey

Replying to bill:

Are you saying that it's too short to input any text?

yes. the TextArea? in safari is too short to enter text and if it is empty to begin with, it does not resize as you try to add content. also, attempting to add content is not successful - .attr("value") returns empty.

Also, Textarea was redesigned since the 1.2 release. Are you having problems on the trunk code?

yes. my problem is with trunk (confirmed using revision 16438)

comment:3 Changed 11 years ago by bill

Milestone: tbd1.3
Owner: set to Douglas Hays
Summary: Problem displaying empty dijit.form.Textarea in SafariTextarea: problem displaying empty dijit.form.Textarea in Safari

comment:4 Changed 11 years ago by Douglas Hays

Status: newassigned

comment:5 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [16439]) Fixes #8392. Add check for empty textarea before computing height

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.