Opened 10 years ago

Closed 9 years ago

Last modified 6 years ago

#8387 closed defect (fixed)

TimeTextBox: picker can occlude text box

Reported by: skip Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit - Form Version: 1.2.3
Keywords: timetextbox picker Cc:
Blocked By: Blocking:

Description

Sometimes the TimeTextBox? picker can completely occlude the textbox, which has a huge impact on usability. To reproduce, resize the browser window such that it is approximately the same size as the picker, and then center the textbox in the window vertically. (it might take you a few goes).

I can't use this control unless I find a solution for this, because the behaviour is COMPLETELY unacceptable.

Greg.

Change History (5)

comment:1 Changed 10 years ago by bill

Milestone: tbdfuture
Priority: highnormal
Summary: TimeTextBox picker can occlude text boxTimeTextBox: picker can occlude text box

This could also happen with DateTextBox etc. The difference is that the drop down for TimeTextBox can be quite tall. ComboBox has code in _showResultList() to adjust the drop down size to the available amount of space (by adding a scrollbar), but that's going to be difficult for TimeTextBox since we'd end up with both a scroll bar and the scrolling arrow buttons. Probably we should just address this as part of #7631.

comment:2 Changed 9 years ago by bill

Milestone: future1.6
Owner: set to bill
Status: newassigned

I'll checkin a stopgap fix so this doesn't happen, at least in the majority of cases.

comment:3 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22580]) Various [stop gap] fixes to TimeTextBox, although still wondering about full rewrite as per #7631, or replacing custom scrolling with native scrollbar like ComboBox has. Fixes include:

  • limit drop down to 10 entries so that (in the majority of cases) it won't overlap the <input> box (fixes #8387)
  • same as ComboBox, make typing automatically open the dropdown, and once the user has started typing or backspacing the dropdown list is filtered by what's in the <input> (fixes #11486)
  • fix recently introduced problem (with _HasDropDown conversion of _DateTimeTextBox, refs #6416) where drop down becomes detached from <input> when it appears above the input and then user types text to further filter the values shown
  • add more tests for TimeTextBox; they previous tests were very sparse; tests include check of current filtering sort order (refs #11485)

!strict as usual.

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form

comment:28 Changed 6 years ago by bill

In [30661]:

Refactor TimePicker to be a traditional drop down list with a scrollbar, like ComboBox. Fixes #7631, #14719 !strict, and refs #8387, #16730 tangentially. Note that the visibleRange option is no longer supported, as it no longer makes sense. If specified, it will be ignored.

Note: See TracTickets for help on using tickets.