Opened 10 years ago

Closed 7 years ago

#8360 closed defect (wontfix)

autoHeigh does not work property if grid has horizontal scroll bar

Reported by: romankuzmik Owned by: Bryan Forbes
Priority: high Milestone: future
Component: DojoX Grid Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

simple add 'style="width:200px;"' to the table tag in 'autoHeight=5 (7 elements)' example from dojox\grid\tests\test_data_grid_autoheight.html. And most likely you'll see only 4 rows instead of 5.

The problem is the view area size calculation algorithm does not include scrolled bar height. And if this bar is displayed then viewable area is the scroller bar height smaller than it have to be.

Attachments (1)

grid_autoHeight_error.gif (6.1 KB) - added by romankuzmik 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by romankuzmik

Attachment: grid_autoHeight_error.gif added

comment:1 Changed 10 years ago by Bryan Forbes

Milestone: tbdfuture

comment:2 Changed 7 years ago by Bryan Forbes

Resolution: wontfix
Status: newclosed

This is a chicken and egg problem: the grid needs to know if the contents will be scrolled, but it won't know that until after rendering. Marking as "wontfix" because the grid already does enough calculating without adding more to get rid of an edge case.

Note: See TracTickets for help on using tickets.