Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#832 closed defect (invalid)

onLoad event does not work on IE when Editor2 widget is used

Reported by: csahin2005@… Owned by: dylan
Priority: high Milestone:
Component: General Version: 0.2
Keywords: onLoad IE Editor2 Cc: evrim@…
Blocked By: Blocking:

Description

onLoad event does not work on IE when Editor widget is used FF and Opera works well

Change History (9)

comment:1 Changed 13 years ago by dylan

Milestone: 0.4

onload when using dojo's onload facility, or using an inline body onload attribute. If the latter, you should be using the former. If the former, please file a testcase.

comment:2 Changed 13 years ago by dylan

Resolution: worksforme
Status: newclosed

comment:3 Changed 13 years ago by evrim@…

Keywords: Editor2 added
Priority: highestnormal
Resolution: worksforme
Status: closedreopened

To set initial contents of editor2 I use dojo.event.connect to hook to onLoad event of Editor2 widget and do editor.replaceEditorContent(). Why can be found at: http://trac.dojotoolkit.org/ticket/1264

dojo.event.connect works for FF 1.5.0.6 but does not work for IE6.

comment:4 Changed 13 years ago by guest

Summary: onLoad event does not work on IE when Editor widget is usedonLoad event does not work on IE when Editor2 widget is used

comment:5 Changed 13 years ago by liucougar

try onEditorLoad instead

comment:6 Changed 13 years ago by dylan

Cc: evrim@… added

evrim@…, does onEditorLoad work for you?

comment:7 Changed 13 years ago by dylan

Owner: changed from anonymous to dylan
Status: reopenednew

comment:8 Changed 13 years ago by evrim@…

Resolution: invalid
Status: newclosed

alright, the problem was in fact IE was faster than gecko to load the editor. So, this was not a bug but a timing problem. Sorry for bothering dojo people.

comment:9 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.