Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#8289 closed enhancement (worksforme)

ComboBox: tab-complete but not autocomplete

Reported by: david Owned by: haysmark
Priority: high Milestone: future
Component: Dijit - Form Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

ComboBox? uses the property autocomplete to decide whether or not pressing tab selects the current option. Also tied to this option is the Safari-like autocompletion of the text in the box as you type. Can we separate out this behavior? It'd be very helpful to be able to have tab select the current option without the annoying (IMO) fill-in-text-as-you-type.

Change History (5)

comment:1 Changed 11 years ago by Douglas Hays

Milestone: tbdfuture
Owner: set to haysmark

comment:2 Changed 10 years ago by haysmark

David, I tried this in all browsers in the 1.2 and 1.3 branches and I can't reproduce it.

Steps I took in each browser:

  1. Load test_ComboBox
  2. Click inside the first ComboBox? (autocomplete=false)
  3. Arrow down to Alaska
  4. Press tab. The onChange box changes to Alaska.

Then I also tried:

  1. Load test_ComboBox
  2. Click inside the first ComboBox? (autocomplete=false)
  3. Type in "Alaska"
  4. Press tab. The onChange box changes to Alaska.

comment:3 Changed 10 years ago by david

I want to be able to type "alas" and hit Tab to have "Alaska" selected. But I don't want auto-complete of the text in the field to take place at the same time. Think about it this way, I like Gmails behavior of giving you suggestions without adding "aska" to your text field. I very much loathe Safaris URL bar assuming the rest of a URL for me (auto-complete).

I hope that makes sense.

comment:4 Changed 10 years ago by haysmark

Resolution: worksforme
Status: newclosed

Looked at the Google suggestion box again, if you type in something into the box, the list of suggestions appears but the text does not autocomplete until you arrow down to select an item from the menu. This is the same as the Dojo ComboBox?'s autocomplete=false behavior except the ComboBox? also highlights the part the user did not type. You only get the "autocomplete as you type" behavior with autocomplete=true; you can still select an option with the Tab key with autocomplete=false.

The behavior of the Tab key does not seem tied to the autocomplete flag and always either accepts the value selected in the menu when present, or else accepts the value the user typed.

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.