Opened 10 years ago

Closed 10 years ago

#8287 closed defect (fixed)

Regression from 1.1.X: BorderContainer Splitter resize is extremely slow when resize reducing pane containing iframe

Reported by: Jared Jurkiewicz Owned by: Adam Peller
Priority: high Milestone: 1.3
Component: Dijit Version: 1.2.3
Keywords: Cc:
Blocked By: Blocking:

Description

Regression from 1.1.X: BorderContainer? Splitter resize is extremely slow when resize reducing pane containing iframe.

The problem occurs when trying to compress an iframe contained within a pane. Stretch the pane left (increase), expands fine and quickly. Do it to the right (reduction), compression is very slow and flaky.

This problem occurs on 1.2.X and trunk (1.3). It does not occur on 1.1.X, therefore, regression.

There is a testcase attached that consists of two files, test.html and test2.html. test.html does the basic layout and defines the iframe that loads test2.html.

They go in the root of you dojo extract. It will work fine on dojo 1.1.X, but work terribly on 1.2.X or later.

Testcase will follow.

Attachments (2)

test.html (1.3 KB) - added by Jared Jurkiewicz 10 years ago.
Main test page
test2.html (44 bytes) - added by Jared Jurkiewicz 10 years ago.
Secondary test page loaded by iframe

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Jared Jurkiewicz

Attachment: test.html added

Main test page

Changed 10 years ago by Jared Jurkiewicz

Attachment: test2.html added

Secondary test page loaded by iframe

comment:1 Changed 10 years ago by liucougar

this is the exact same issue fixed in #8234, but that is for splittercontainer (rather than bordercontainer itself), just want to point this out, maybe useful

comment:2 Changed 10 years ago by Adam Peller

Thanks, Cougar. Yes, Bill pointed this out and suggested a separate style. We should leave SplitContainer? as-is, since we don't want to carry additional style rules for deprecated code. See [16094] This still does not work in IE8 for some reason.

comment:3 Changed 10 years ago by Adam Peller

(In [16216]) Undo regression from [16094]. Fixes #8332, Refs #8287

comment:4 Changed 10 years ago by bill

Milestone: tbd1.3
Owner: set to Adam Peller
Priority: normalhigh

Isn't this fixed by the above checkin?

comment:5 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: newclosed

seems so. closing.

Note: See TracTickets for help on using tickets.