Opened 5 years ago

Closed 13 months ago

#8242 closed defect (patchwelcome)

Grid content does not display once containing div exceeds height threshold on FF3

Reported by: ptwobrussell Owned by:
Priority: high Milestone: future
Component: DojoX Grid Version: 1.2.1
Keywords: Cc:
Blocked by: Blocking:

Description

I recently hooked up a dojox.grid.DataGrid to a QueryReadStore with a huge volume of data (1M+ records) and noticed that on FF3.0.4 on the Mac that the content simply does not display. After some investigation, this appears to be a Mozilla specific issue. (The grid works fine on Firefox)

See https://bugzilla.mozilla.org/show_bug.cgi?id=468386 for the bug report I filed over there.

To be clear, the contentNode that is being produced is of the following form:

<div hidefocus="hidefocus" dojoattachpoint="contentNode" class="dojoxGridContent" style="height: 3.19998e+7px; width: 199px;">

and the extremely large height is causing the issue.

On 8-15-08, the HEAD of trunk seemed to work (that was lightly before 1.2 was released, IIRC), so I'm assuming this is actually a regression in the refactored code base.

Change History (8)

comment:1 Changed 5 years ago by toonetown

  • Milestone changed from tbd to 1.3
  • Owner changed from BryanForbes to toonetown
  • Priority changed from normal to high

comment:2 Changed 5 years ago by toonetown

  • Milestone changed from 1.3 to future

comment:3 Changed 5 years ago by toonetown

Do you have a test case that you could attach which demonstrates this issue?

comment:4 Changed 5 years ago by ptwobrussell

Yea, for a test case checkout the example at the end of this article that uses the QueryReadStore - http://www.linuxjournal.com/article/10380

The best I can tell this is still an issue. I am here at OSCON finalizing my slides and can't seem to get it to work with the latest Firefox. It does work fine in Safari though. If you start work on this ticket and need IE feedback I could fire up a VM and give you reports there as well.

Bottom line - I'd recommend not making this "future" because this is kind of a big deal for people who want to use the grid for server backed data. I know that's easy for me to say since I'm not the one fixing this, but give it some thought...

comment:5 Changed 5 years ago by toonetown

  • Priority changed from high to normal

comment:6 Changed 4 years ago by toonetown

  • Owner toonetown deleted

Unassigning my tickets.

comment:7 Changed 13 months ago by bill

DojoX Grid and EnhancedGrid are deprecated in favor of dgrid and gridx.

You should upgrade your code to use one of those two grids.

We will consider patches to the old DojoX Grid code though.

comment:8 Changed 13 months ago by bill

  • Resolution set to patchwelcome
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.