Opened 11 years ago

Closed 10 years ago

#8238 closed defect (wontfix)

dojox.grid.DataGrid, Safari 3.1.2, Mac OS X 10.5: onStyleRow results in selection bar's and view's rows not being aligned

Reported by: holgerthurow Owned by: Bryan Forbes
Priority: high Milestone: 1.3
Component: DojoX Grid Version: 1.2.0
Keywords: dojox.grid.DataGrid, onStyleRow, Safari Cc:
Blocked By: Blocking:

Description

The Grid initialization params:

var grid = new dojox.grid.DataGrid({
    query: { name: '*' },
    store: jsonStore,
    clientSort: true,
    onStyleRow: onStyleRow,
    structure: layout
}, document.createElement('div'

));

Attachments (1)

DataGrid_onStyleRow_Safari_3_1_2.png (35.8 KB) - added by holgerthurow 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by holgerthurow

comment:1 Changed 11 years ago by holgerthurow

Sorry, it doesn't has to to with setting onStyleRow. Rendering the grid again with a delay of about 1 second solves the problem. So I do addOnLoad

var grid = new dojox.grid.DataGrid({
    query: { name: '*' },
    store: jsonStore,
    clientSort: true,
    onStyleRow: onStyleRow,
    structure: layout
}, document.createElement('div'))

dojo.byId("gridContainer").appendChild(grid.domNode);
grid.startup();
					
setTimeout( dojo.hitch(grid, "render"), 1000 )

comment:2 Changed 11 years ago by holgerthurow

I found the problem caused by the images loading one after another and changing the row height after the grid has finished to render its content. So I have to rerender after all images are loaded.

comment:3 Changed 10 years ago by Bryan Forbes

Milestone: tbd1.3

comment:4 Changed 10 years ago by Bryan Forbes

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.