Opened 10 years ago

Closed 7 years ago

#8208 closed defect (invalid)

grid.rowHeightChanged(rownum) does nothing

Reported by: flaggedatbest Owned by: flaggedatbest
Priority: high Milestone: future
Component: DojoX Grid Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

I have expanded the subgrids example to include a hidden cell in each subgrid, that can be shown by clicking on an image in each subgrid. This causes the height of the subgrid to change.

The method that makes the subgrid larger does this: subGrid.updateRow(inIndex); and the buildGrid does this after the render: inCell.grid.rowHeightChanged(inRowIndex);

The problem is that rowHeightChanged(row) does nothing - the cell that contains the subgrid is at a fixed size so the larger subgrid is partially hidden by the main grid.

Change History (4)

comment:1 Changed 10 years ago by dante

Component: GeneralDojoX Grid
Owner: changed from anonymous to Bryan Forbes

comment:2 Changed 10 years ago by Bryan Forbes

Milestone: tbdfuture

comment:3 Changed 7 years ago by Bryan Forbes

Owner: changed from Bryan Forbes to flaggedatbest
Status: newpending

Is this still an issue? If so, please attach a test case. I should also note that sub-grids have been replaced by TreeGrid.

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.