Opened 11 years ago

Closed 7 years ago

#8201 closed defect (duplicate)

TextBox: doesn't remember login data (i.e Firefox Password-Store)

Reported by: melchior Owned by:
Priority: high Milestone: 2.0
Component: Dijit - Form Version: 1.2.1
Keywords: dijit support, browser, dijit, firefox, form, login, password, save, store Cc:
Blocked By: Blocking:

Description

hi,

I'm using dojo for a really long time but I've never seen that dijit textBox/form combo saves data while providing a login form like normal html input form components.

I don't know if this was ever provided. also can't find any information by google or by dojo search.

would be nice to get feedback. thx and great work with dojo! I'm loving it.

greets, melchior

Change History (4)

comment:1 Changed 11 years ago by dante

Resolution: invalid
Status: newclosed

afaik, this is a limitation of the way Dijit is swapping natural nodes out with the template nodes. It is not a supported feature of Dijit, though the form inputs degrade to whatever they were instantiated as in the non-js case, so if you are doing the progressive use case, you should retain native auto completion. it just isn't feasible to maintain/track within Dijit.

comment:2 Changed 11 years ago by bill

Milestone: tbd2.0
Resolution: invalid
Status: closedreopened
Summary: TextBox dijit doesn't remember login data (i.e Firefox Password-Store)TextBox: doesn't remember login data (i.e Firefox Password-Store)

This is similar to #5424 and #6920 although in this case the template doesn't have two <input> nodes but rather just one.

I think we might be able to fix this by putting back the original <input> node on page unload. Not sure if that would work. Anyway I'm going to mark it for 2.0 for consideration along w/the above two tickets.

comment:3 Changed 9 years ago by bill

Component: DijitDijit - Form

comment:4 Changed 7 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Duplicate of #5424.

Note: See TracTickets for help on using tickets.