Opened 10 years ago

Closed 10 years ago

#8194 closed defect (wontfix)

ComboButton: can't use left arrow key to move from arrow icon to button portion

Reported by: Scott Lewis Owned by: Becky Gibson
Priority: high Milestone: tbd
Component: Accessibility Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

Keyboard manipulation: difficulty getting to button portion -- odd input focal (ie, the dotted outline) shift when using the mouse.

Change History (4)

comment:1 Changed 10 years ago by bill

Component: GeneralDijit - LnF
Owner: anonymous deleted

You'll need to be much more specific about what the issue is. I tried http://download.dojotoolkit.org/release-1.2.1/dojo-release-1.2.1/dijit/tests/form/test_Button.html and the keyboard manipulation is working fine for me. Perhaps you need to include some images too.

Also, please try to write descriptive summaries (ie, titles) stating what the issue is.

comment:2 Changed 10 years ago by Scott Lewis

click on the dropdown arrow. You get the focus outline. How do you move the focus with the keyboard to the button part to the left? alt+tab does it but shouldn't the back arrow do it?

comment:3 Changed 10 years ago by bill

Component: Dijit - LnFAccessibility
Owner: set to Becky Gibson
Summary: ComboButtonComboButton: can't use left arrow key to move from arrow icon to button portion

I assume you are referring to the left arrow key, and shift-tab (not alt-tab)

Hmm, I'm not sure why we are using shift-tab instead of left-arrow, but I think this is intentional based on a very long discussion with the accessibility group. But, I'll let Becky answer/decide...

comment:4 Changed 10 years ago by Becky Gibson

Resolution: wontfix
Status: newclosed

It was decided that both parts of the combobutton would be in the tab order rather than using the arrow keys to move between each piece. This is because there is no way to indentify the entire combobutton to a screen reader. Thus, when a screen reader tabbed to a combobutton, they would have no way of knowing that it was a two part button and not know to use the arrow key to move between the two parts. Since the combobutton functions like two separate buttons - one with the default action and another that behaves as a drop down button, the decision was made to put both parts into the tab order. We could implement the left and right arrow keys as a convenience for keyboard users but that may have some implications for use of a combobutton within a toolbar. I'll created and enhancement request ticket: #8474 Currently if the user is within the drop down menu portion of the button, they must press escape to close the drop down. That will refocus the arrow portion of the button and then press shift-tab to focus the default portion.

Note: See TracTickets for help on using tickets.