Opened 11 years ago

Closed 11 years ago

#8183 closed defect (invalid)

DataGrid 1.2: column disappears when resized

Reported by: yherve Owned by: anonymous
Priority: high Milestone: tbd
Component: General Version: 1.2.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hello Dojo Team,

I have a very basic DataGrid? 1.2 (statically created) with 3 columns (col1, col2 and col6). Try to resize to enlarge the col2. Keep enlarging the column out of the browser boundary until the 'col6' completely disappears on the right of the screen.

As you would expect, an horizontal scrollbar appears, but when you scroll this scrollbar, the 'col6' is not here anymore (see attachment)

pb reproduced with dojo-2008-11-25 nightly build on ff3 win XP and chrome (not tried any other browser)

thanks

Yann

Attachments (1)

trac8183.html (3.5 KB) - added by yherve 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by yherve

Attachment: trac8183.html added

comment:1 Changed 11 years ago by Nathan Toone

Resolution: invalid
Status: newclosed

This is because you have your column "Column 6" as width "auto" - which means that it will take up the remaining space...once you resize your columns to be wide enough to require the scroll, the "auto" width gets calculated as "0".

Try using percent widths on your columns instead of auto.

Note: See TracTickets for help on using tickets.