Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#8179 closed defect (wontfix)

Typo in loader_xd localization

Reported by: dylan Owned by: James Burke
Priority: high Milestone: future
Component: BuildSystem Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

I think this is the right change, but don't want to modify such crucial code without certainty:

Index: _base/_loader/loader_xd.js
===================================================================
--- _base/_loader/loader_xd.js  (revision 15904)
+++ _base/_loader/loader_xd.js  (working copy)
@@ -447,7 +447,7 @@
        //See if the bundle we are going to use is already loaded.
        var bundleResource = dojo.getObject([moduleName, "nls", bundleName].join("."));
        if(bundleResource && bundleResource[fixedBestLocale]){
-               bundle[jsLoc.replace('-', '_')] = bundleResource[fixedBestLocale];
+               bundleMap[jsLoc.replace('-', '_')] = bundleResource[fixedBestLocale];
        }else{
                //Need to remember what locale we wanted and which one we actually use.
                //Then when we load the one we are actually using, use that bundle for the one

Change History (5)

comment:1 Changed 11 years ago by James Burke

Milestone: 1.3future

This bothers me, but its been in there for a while, and we need to wrap up 1.3.

comment:2 in reply to:  1 Changed 10 years ago by wtford

Replying to jburke:

This bothers me, but its been in there for a while, and we need to wrap up 1.3.

Hi, I'm using the latest dojo.xd.js from both google and aol (1.3 July 2, 2009), and they both include the change prescribed by this ticket. The change is wrong, however. "bundleMap" is defined nowhere before that line (line 450, loader_xd.js), so browsers crash when invoking the function. I'm not yet sure what "bundleMap" should be, but I'll post again if I find it. Thoughts anyone?

comment:3 Changed 10 years ago by James Burke

wtford: do you have a test page that shows an error being thrown by the code? That would help identify the issue. The previous code change that had "bundle" should have also failed, but I suspect the loader is not even following that if path. However if you have a test page that shows the issue, that would help.

comment:4 Changed 8 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

comment:5 Changed 8 years ago by Adam Peller

loader/builder has been replaced, and there is no longer an xd variant

Note: See TracTickets for help on using tickets.