Opened 11 years ago

Closed 11 years ago

#8168 closed defect (fixed)

[regression] TabContainer: nested layout widgets from href

Reported by: bill Owned by:
Priority: high Milestone: 1.2.3
Component: Dijit Version: 1.2.2
Keywords: Cc:
Blocked By: Blocking:

Description

See test_TabContainer.html, on the "Sub TabContainer from href". Nothing shows up.

Regressed in 1.2.2.

Change History (4)

comment:1 Changed 11 years ago by bill

Version: 1.2.11.2.2

comment:2 Changed 11 years ago by bill

Resolution: fixed
Status: newclosed

I broke this in [15797], although that [15795] seems like the real culprit.

Problem was that the resize code (for resizing a single-child layout widget) wasn't getting called after downloading an href.

Fixed in [15877]. There might be some further optimizations in that the code in startup() calling resize() (if there's a single child) may no longer be necessary.

comment:3 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: closedreopened

Looks like the change in [15877] broke the accordion pane tests as well.

comment:4 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

Ugh, didn't even realize that AccordionContainer extends StackContainer.

Now that StackContainer._showChild() calls resize() on the child, AccordionPane needs to support resize correctly.

Fixed in [15911].

Note: See TracTickets for help on using tickets.