Opened 11 years ago

Closed 11 years ago

#8155 closed defect (wontfix)

IE8 a11y: dialog title is not announced

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

With IE8 beta 2 and JAWS 10, "dialog" and the dialog title are not announced when a dialog is opened. This is a placeholder ticket as I believe this is an IE8 issue since with Firefox 3 and JAWS 10, "dialog" and the title are properly announced. The cause of the issue seems to be that IE8 does not properly supported the labelledby property that the dialog uses to assign the dialog title.

Change History (4)

comment:1 Changed 11 years ago by Becky Gibson

this has not improved with IE 8 RC1 and JAWS 10.0.1031U

comment:2 Changed 11 years ago by Becky Gibson

This has not improved with IE 8 public RC1 and JAWS 10.0.1074U - dialog title is still not announced

comment:3 Changed 11 years ago by Becky Gibson

Milestone: 1.31.4

moving to 1.4 since is an IE 8 issue more than a Dojo one.

comment:4 Changed 11 years ago by Becky Gibson

Resolution: wontfix
Status: newclosed

Closing as wontfix since this is an IE 8 issue and not a djiit dialog issue and I don't know when there will be an update to IE. The YUI dialog examples also do not work in IE 8 - the dialog information is not spoken (because YUI also uses labelledby to set the dialog title). I updated the dialog docs on dojo campus to indicate that the dialog information and title is not spoken in IE 8.

Note: See TracTickets for help on using tickets.