Opened 11 years ago

Closed 10 years ago

#8154 closed defect (wontfix)

IE8 a11y: pressed state of toggle buttons not spoken

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.2.1
Keywords: IE8 Cc:
Blocked By: Blocking:

Description

With IE 8 beta 2 and JAWS 10, the pressed state of toggle buttons is not spoken. This is a placeholder ticket since I believe the problem is in IE8. With Firefox 3 and JAWS 10 the pressed state is not spoken when the button gets focused, but it is spoken when the button goes from not pressed (toggle off) to pressed (toggle on)

Change History (3)

comment:1 Changed 11 years ago by Becky Gibson

In IE8 RC1 the pressed state is now spoken when the button gets focus and the state is pressed but it is still not spoken when the button changes from not pressed to pressed. With FF 3.0.5 and JAWS 10.0.1031U the pressed state is now spoken when the button gets focus and when the state changes. Leaving this open to test with final release of IE8 but it is not critical.

comment:2 Changed 11 years ago by Adam Peller

Milestone: 1.31.4

comment:3 Changed 10 years ago by Becky Gibson

Resolution: wontfix
Status: newclosed

Closing since I do not expect this behavior to change. I suspect it will work properly on Vista but I don't have a machine to confirm. Noting this in the documentation and closing.

Note: See TracTickets for help on using tickets.