Opened 11 years ago

Closed 11 years ago

#8153 closed defect (wontfix)

IE8 a11y: properties for tree not spoken

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.2.1
Keywords: IE8 Cc:
Blocked By: Blocking:

Description

In IE 8 beta 2 with JAWS 10, the expanded collapsed state and level information for tree items is not spoken. This is a place holder as I suspect the issue is with IE 8 since the tree works correctly with JAWS 10 and Firefox 3.

Change History (4)

comment:1 Changed 11 years ago by Becky Gibson

with RC1, the items are properly identified with open/close but the level information is not correct and JAWS will often speak the items which are not visible (ie within a closed node). There are still issues with other ARIA tree examples so this is still an IE 8 issue. http://test.cita.uiuc.edu/aria/tree/ http://cookiecrook.com/test/aria/tree/ariatree.html

comment:2 Changed 11 years ago by Becky Gibson

This remains the same with the public RC1 (8.0.6001.18372). Open closes are spoken but all of the items under a node are spoken whether or not they are visible and there is no level information spoken.

comment:3 Changed 11 years ago by Becky Gibson

Milestone: 1.31.4

moving to 1.4 since is an IE 8 issue more than a Dojo one.

comment:4 Changed 11 years ago by Becky Gibson

Resolution: wontfix
Status: newclosed

Since Firefox is able to determine the level information, IE 8 should be able to as well. I am closing this as wontfix since I see it as an IE 8 limitation and I don't know when the next update to IE will occur. IE 8 does not speak the open/close information but the other tree example provided above still do not work correctly in IE 8. The dijit tree works reasonably well. I've updated the tree docs on dojo campus to indicate that IE 8 does not speak the level information.

Note: See TracTickets for help on using tickets.