Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#8141 closed defect (duplicate)

Textarea: text pasted into textarea widget omits some spaces in FF3

Reported by: sfox Owned by: anonymous
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

In Firefox 3.04 (mac) pasting non-trivial pieces of text into a dijit Textarea results in (seemingly) random spaces between words being omitted. To reproduce:

  1. Open the test page included in the standard dojo release:

dojo-release-1.2.0-src/dijit/tests/form/test_Textarea.html

  1. Cut the lipsum text out of the large text area.

(box resizes to a single line)

  1. Paste the same lipsum text back into the box.

Text looks fine in the box but hitting 'view data' reveals that the 11th and 12th words (and others later on) are run together: nonummynibh instead of nonummy nibh

As a result programmatically pulling out the value of textareas results in text with some missing spaces. Which makes this a not very useful widget--my users like their spaces :)

Seems to be a FF bug of some sort (I don't see the problem in Safari) but if there's a dojo-side fix it would be appreciated.

Change History (2)

comment:1 Changed 11 years ago by bill

Component: GeneralDijit
Milestone: tbd1.3
Resolution: duplicate
Status: newclosed
Summary: text pasted into textarea widget omits some spaces in FF3Textarea: text pasted into textarea widget omits some spaces in FF3

Good eye :-). This was fixed in [15663]: Fixes #8065. Changed nbsp entities to spaces. This reverts a change made in [10045] but I couldn't figure out why it was changed. innerText could not be used since it consolidates multiple spaces, and the Firefox equivalent textContent throws away newlines.

Will be in 1.3.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.