Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#8122 closed defect (fixed)

robot: investigate FF3 with Java 6 on Linux

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 1.4
Component: TestFramework Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by haysmark)

I tested the robot with FF2 and the Java 1.4 plugin on Linux but it remains to be seen whether FF3 and Java 1.6 work on Linux. Linux is special because Java on Linux uses the X11 event queue to simulate user input instead of the actual cursor and keyboard.

Configuration: FF3.0.4 Java 1.6.0_07-b06 symlink sun-java6-plugin into FF plugins directory

Attachments (2)

8122.patch (971 bytes) - added by haysmark 10 years ago.
Fixes #8122. Prevent Mac/Safari? fix from firing on Linux.
DOHRobot.jar (40.6 KB) - added by haysmark 10 years ago.
New JAR file.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by haysmark

Milestone: tbdfuture

Successfully reproduced the crash on an up to date Linux system. The test runs but crashes the browser at the very end, when the JS uninits the applet. Cause is still unclear.

comment:2 Changed 10 years ago by haysmark

Description: modified (diff)

Update: my FF2 was pointing to Java 1.4, not Java 1.5. After updating the system, this combination stopped working and was what produced the crash on the end of the test. When I was attempting to run FF3, it would instead point to the FF2 in my path unbeknown to me.

My FF3 install was also pointing to the nc7-gcc plugin. This caused the browser to crash when loading the browser with a robot page. When I pointed it to the plain nc7 plugin, the test worked as expected with no crash at the end. Hmm.

comment:3 Changed 10 years ago by haysmark

Tried the robot on UK's Ubuntu system today. They have:

  • FF 3.0.6
  • java version "1.6.0_07"
  • Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
  • Java HotSpot?(TM) Client VM (build 10.0-b23, mixed mode, sharing)
  • Linux version 2.6.24-22-generic (buildd@vernadsky)
  • (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Mon Nov 24 18:32:42 UTC 2008
  • Intel i486 family processor

This FF3 was configured to use the Java 1.6 plain nc7 plugin as on my machine. It worked fine; in fact, it worked even better than my Linux machine because the actual mouse moved around (as with Windows and OS X), instead of a second invisible mouse.

Sun says that their plugin didn't support 64 bit browsers until December 2008 with Java 6u12.

Bug report: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4802695

Java early release descriptions: https://jdk6.dev.java.net/6uNea.html

Maybe this is a clue to people's issues with the robot?

Changed 10 years ago by haysmark

Attachment: 8122.patch added

Fixes #8122. Prevent Mac/Safari? fix from firing on Linux.

Changed 10 years ago by haysmark

Attachment: DOHRobot.jar added

New JAR file.

comment:4 Changed 10 years ago by haysmark

An IBM team reproduced the problem. They had the right plugin, but it turns out Linux does not like the Mac/Safari? fix in the Java code when connecting to remote servers like dtk.org. Appended the fix.

comment:5 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [17627]) Fixes #8122. Skip security manager socket intercept for linux.

comment:6 Changed 10 years ago by Douglas Hays

Milestone: future1.4
Note: See TracTickets for help on using tickets.