Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#8121 closed defect (fixed)

InlineEditBox+NumberTextBox=NaN?

Reported by: haysmark Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

http://archive.dojotoolkit.org/nightly/checkout/dijit/tests/test_InlineEditBox.html

Click the box next to "please remit". You get NaN for the value. Shouldn't it be blank as the inline text indicated?

If you then clear the erroneous NaN so the box just has "" (which is valid input since it says so), you get the letters NaN as the inlined value, even though the value the user entered was blank.

Change History (5)

comment:1 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3
Owner: changed from bill to Douglas Hays

comment:2 Changed 11 years ago by Douglas Hays

Status: newassigned

comment:3 Changed 11 years ago by Douglas Hays

regression caused by [15513]

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

[15802] Fixes #8121. Add _getDisplayedValueAttr function to NumberTextBox? to deal with NaN.

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.