Opened 11 years ago

Closed 9 years ago

#8112 closed defect (worksforme)

[patch] Dojox grid : CheckboxEditor do not initialize properly

Reported by: rdunklau Owned by:
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hello.

The grid CheckBoxEditor? initializes to false, independtly from the value.

This is noticeable only the first time you edit a cell.

To reproduce the bug, see the attached file and double click in the 7th column in a row for which its value is true.

Please also see the attached patch, which should correct this bug.

Attachments (2)

test_grid_layout.html (3.8 KB) - added by rdunklau 11 years ago.
Test Grid Layout updated to sow the bug
dijit.js.patch (463 bytes) - added by rdunklau 11 years ago.
Patch correcting the bug

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by rdunklau

Attachment: test_grid_layout.html added

Test Grid Layout updated to sow the bug

Changed 11 years ago by rdunklau

Attachment: dijit.js.patch added

Patch correcting the bug

comment:1 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.3

comment:2 Changed 11 years ago by Bryan Forbes

Priority: normalhigh
Summary: Dojox grid : CheckboxEditor do not initialize properly[patch] Dojox grid : CheckboxEditor do not initialize properly

comment:3 Changed 10 years ago by bill

Milestone: 1.31.4

1.3rc1 has been release; bumping remaining tickets to 1.4 (except for documentation/testing tickets)

comment:4 Changed 10 years ago by Nathan Toone

Milestone: 1.41.5
Owner: changed from Bryan Forbes to Nathan Toone

Moving non-regressions to 1.5

comment:5 Changed 9 years ago by Nathan Toone

Milestone: 1.5future
Owner: Nathan Toone deleted

Moving my tickets to future, as I am not currently working on them.

comment:6 Changed 9 years ago by evan

Milestone: future1.6
Resolution: worksforme
Status: newclosed

Not able to reproduce this issue with the attached test case, 'Column 7' reflects correct boolean values in store.

Note: See TracTickets for help on using tickets.