Opened 11 years ago

Closed 8 years ago

#8071 closed defect (fixed)

Bar Chart X-Axis Labels are incorrectly possitioned in RTL

Reported by: taras Owned by: Eugene Lazutkin
Priority: high Milestone: 1.7
Component: Charting Version: 1.2.1
Keywords: bidi Cc:
Blocked By: Blocking:

Description

In Bar Chart X-Axis Labels are incorrectly possitioned in RTL

Please see: dojotoolkit/dojox/charting/tests/test_chart2d.html

When html tag dir='rtl'

Attachments (1)

PieBug.gif (8.3 KB) - added by taras 11 years ago.
Bar Chart Wrong Location of X-axis labels. Example

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by taras

Attachment: PieBug.gif added

Bar Chart Wrong Location of X-axis labels. Example

comment:1 Changed 11 years ago by bill

Component: GeneralCharting
Owner: changed from anonymous to Eugene Lazutkin

comment:2 Changed 11 years ago by Adam Peller

Keywords: bidi added

comment:3 Changed 11 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned

We need to audit charting for bidi problems and devise ways to deal with a11y.

comment:4 Changed 11 years ago by Eugene Lazutkin

Related to #7569.

comment:5 Changed 8 years ago by cjolif

Milestone: future1.7
Resolution: fixed
Status: assignedclosed

I can't reproduce anymore in 1.7. The chart is not reversed but the axis labels correctly display.

Note: See TracTickets for help on using tickets.