Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#8069 closed defect (worksforme)

DateTextBox: problem with manually enterign dates

Reported by: mtomczak Owned by: Adam Peller
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

When a user inputs a value: 11-10-08, the entered value springs to 11-10-0008 but when you click into the input and the calendar is shown it displays the year 1908. This should be more consistent.

Change History (4)

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from anonymous to Adam Peller

can you point me at a specific test and verify that this is a problem with the latest code (either 1.2 or trunk) Since Dojo 1.0, we applied some y2k type fixes that should have taken care of this.

comment:2 Changed 11 years ago by bill

Component: GeneralDijit
Summary: Problem With dijit.form.DateTextBox and manually enterign datesDateTextBox: problem with manually enterign dates

Does http://download.dojotoolkit.org/release-1.2.1/dojo-release-1.2.1/dijit/tests/form/test_DateTextBox.html work for you?

You should also list whate locale your machine is.

(Although given that this ticket is marked as version=1.0 it's probably fixed already)

comment:3 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

Please re-open if you can reproduce this bug on a recent build.

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.