Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#8066 closed defect (duplicate)

Removing words in a dijit.form.Textarea will remove spaces in the underlying html textarea

Reported by: rodeoclown Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.2.1
Keywords: Cc:
Blocked By: Blocking:

Description

If you have text "blah foo bar" and delete "foo ", the space in front of it is replaced with a  , which is then filtered out in the Textarea.setValue() function.

This means that words can be concatenated, but this won't be visible until the value from the text area is saved, and then retrieved later.

I spent 4 and a half hours today tracking it down, and the problem is on line 90 of Textarea.js - the very first replace regEx is stripping out   and replacing it with "".

My fix was to remove the   from that regex, and add another replace call to the list replacing   with " ".

Change History (2)

comment:1 Changed 11 years ago by bill

Resolution: duplicate
Status: newclosed

Dup of #8065.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.