Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#8043 closed defect (invalid)

Strange dijit.form.Form input type="image" submission behavior on IE

Reported by: Josh Trutwin Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2.0
Keywords: dijit.form.Form Internet Explorer ie type="image" Cc:
Blocked By: Blocking:

Description

Sorry for the poor title, best I could do.

I will attach a test case - every now and then I notice really odd behavior on ie6 browsers with dijit.form.Form and form submissions. In particular we have issues when using input type="image" to submit our forms - these work ok on firefox browsers, but in ie6, oddities abound. In ie6, it appears that it only sends form data (POST) to server for form stuff AFTER the type=image, anything above is not sent.

Anyway, to see what I'm getting at, load the test in ie6 and press the last Save image. In ie6 you see the POST vars for the image coords and the form object (hidden fields) in the html underneath the image - the ones above are not sent. Running the same thing in firefox sends all POST data.

The php script is simply: var_dump($_REQUEST);

I know I have seen other odd behavior with ie and dijit.form.Form - but this is the first reproducable test case I can create at the moment as these are hard to track/debug...

Attachments (3)

test_input_type_image.html (2.6 KB) - added by Josh Trutwin 11 years ago.
Test Case - note, replace my path to dojo 1.2
greensave.png (677 bytes) - added by Josh Trutwin 11 years ago.
my save image
test_button.html (2.4 KB) - added by Josh Trutwin 11 years ago.
Test case for the comment about buttons and 405 error on ie6/ie7

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Josh Trutwin

Attachment: test_input_type_image.html added

Test Case - note, replace my path to dojo 1.2

Changed 11 years ago by Josh Trutwin

Attachment: greensave.png added

my save image

comment:1 Changed 11 years ago by Josh Trutwin

Confirmed that button Save image also does not work as expected as well on ie7 - only sends form elements underneath the input type="image" to server.

comment:2 Changed 11 years ago by Josh Trutwin

Another test case to add - this time adding a TabContainer? to the form and some validation - works just great on firefox browsers. On either ie6/ie7 get a 405 error code returned.

Changed 11 years ago by Josh Trutwin

Attachment: test_button.html added

Test case for the comment about buttons and 405 error on ie6/ie7

comment:3 Changed 11 years ago by bill

Owner: set to Douglas Hays

Hmm, that seems very strange.

Note that you can (should?) be using iconSrc to specify an image in a button. (You need to specify the image path in the CSS file)

comment:4 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3
Resolution: invalid
Status: newclosed

It's because you have Paragraph tags everywhere and never end them. I added a bunch of /p tags and it worked.

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.