Opened 11 years ago

Closed 11 years ago

#8037 closed defect (fixed)

validation text box - IE6 - bidi - editing problem

Reported by: mtomczak Owned by:
Priority: high Milestone: 1.2
Component: Dijit Version: 1.0
Keywords: bidi, ie6, validationtextbox Cc: Adam Peller, Douglas Hays
Blocked By: Blocking:

Description

If website elements are displayed rtl and a user inputs a long string the cursor springs back to the beginning of the field and also when a user moves cursor to the left it springs back to the beginning and makes writing very difficult. Additionaly using arrow keys is difficult as they are reversed using right arrow moves cursor to the left and vice versa.

Change History (4)

comment:1 Changed 11 years ago by bill

Can you reproduce this on 1.2? We aren't fixing bugs in 1.0 (or 1.1, for that matter) anymore.

comment:2 Changed 11 years ago by Adam Peller

Cc: Adam Peller Douglas Hays added

comment:3 Changed 11 years ago by Douglas Hays

Bidi is not supported on 1.0

comment:4 Changed 11 years ago by bill

Milestone: tbd1.2
Resolution: fixed
Status: newclosed

Closing since bidi wasn't supported in 1.0 but is support in 1.2 (and maybe 1.1, I forget).

Note: See TracTickets for help on using tickets.