Opened 11 years ago

Closed 11 years ago

#8035 closed enhancement (duplicate)

use dojo.delegate(... instead of dojo.mixin(dojo.clone(... for attributeMaps

Reported by: alex Owned by: alex
Priority: low Milestone: 1.3
Component: Dijit Version: 1.2.0
Keywords: dijit, delegate, mixin, clone Cc:
Blocked By: Blocking:

Description

today, many attribute map properties are specified like this:

    attributeMap: dojo.mixin(dojo.clone(dijit.form._FormWidget.prototype.attributeMap), {
        label: {node: "containerNode", type: "innerHTML" },
        iconClass: {node: "iconNode", type: "class" }
    }),

but could be more efficiently defined as:

    attributeMap: dojo.delegate(dijit.form._FormWidget.prototype.attributeMap, {
        label: {node: "containerNode", type: "innerHTML" },
        iconClass: {node: "iconNode", type: "class" }
    }),

We should make this change globally.

Change History (1)

comment:1 Changed 11 years ago by alex

Resolution: duplicate
Status: newclosed

ugg, dupe of #8034

Note: See TracTickets for help on using tickets.