Opened 11 years ago

Closed 11 years ago

#8009 closed defect (fixed)

potential typo in class name in TabContainer_rtl.css files

Reported by: ptwobrussell Owned by: bill
Priority: high Milestone: 1.3
Component: themes Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

To cut right to the chase, I tracked down an issue in an application I'm working on, and it occurred to me that the "issue" might be a bug in a dijit class declaration. And if it's not a bug, it probably deserves at least a comment in the css to explain what's going on

In the HEAD, the last declaration of TabContainer_rtl.css (all themes) is this:

.dj_ie .tundra .dijitTab .dijitTabInnerDiv{
    width : 1%; 
}

If you look at the rest of the file, that is the only .dj_ie reference. All others are .dj_ie-rtl and for that matter, all other classes have a left-most class of "rtl-something-another".

Is that a bug? For my situation, when I change that width to auto, it fixes my problem (a closeIcon breaking to appear below the tab versus staying inline). If it's not a bug, maybe it should be explicitly commented so that this question doesn't come up again.

Change History (2)

comment:1 Changed 11 years ago by bill

Milestone: tbd1.3
Owner: changed from nonken to bill
Status: newassigned

That strange code is there so the tabs don't extend too far (each one getting a separate row) in RTL mode.

The .dj_ie seemed to be necessary (rather than .dj_ie-rtl) for left and right tabs.

However, I can get it working using .dj_ie-rtl with a !important clause.

comment:2 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in [15648].

Note: See TracTickets for help on using tickets.