Opened 11 years ago

Closed 11 years ago

#7984 closed defect (duplicate)

Dijit: ESC cancels out of edit, cancel dialogs, etc. and do nothing in std form controls

Reported by: David Schwartz Owned by:
Priority: high Milestone: tbd
Component: Dijit - LnF Version: 1.2.0
Keywords: ibm ESC Cc:
Blocked By: Blocking:

Description

This originally came up in a discussion of InlineEditBox? but really addresses all of dijit. ESC should:

  • Cancel out of edit mode for InlineEditBox?
  • Cancel dialog boxes and
  • Cancel pop-up controls such as DateTextBox?
  • Have no other effects on form controls.

Change History (2)

comment:1 Changed 11 years ago by David Schwartz

Dupe of #7983. Needs to be closed.

comment:2 Changed 11 years ago by Adam Peller

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.