Opened 11 years ago

Closed 11 years ago

#7977 closed task (fixed)

[Tree] dijit.Tree templates should be in templates/

Reported by: dante Owned by: dante
Priority: high Milestone: 1.3
Component: Dijit Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

the templates for dijit.Tree are in _tree/ folder off the dijit namespace. We bulk remove templates in the release, and these are missed because they break the pattern set forth by the other widgets. I suggest moving the templates into templates/ folder so the release script will find them without modification.

please pass back if you approve, I'll do the task.

Change History (4)

comment:1 Changed 11 years ago by bill

Owner: changed from bill to dante

Well, the templates are in the tree/ direct by design. The idea was to have all the tree/ stuff (there are a fair number of files) in one directory, so to not interfere with the other widget files.

It doesn't really matter though. You can move them to the dijit/templates, or perhaps to dijit/tree/templates, in order to get the build scripts working.

comment:2 Changed 11 years ago by dante

Status: newassigned

comment:3 Changed 11 years ago by dante

putting them in templates/ keeps it consistent and easy to explain/locate. thanks for the +1

comment:4 Changed 11 years ago by dante

Resolution: fixed
Status: assignedclosed

fixed in [15919]

Note: See TracTickets for help on using tickets.