Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#7947 closed defect (invalid)

GetValue() / attr('value') not consistant for ComboBox vs. FilteringSelect

Reported by: heatherk Owned by:
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

Depending on what you put for searchAttr and labelAttr, ComboBox? does not always return the same result for getValue() as FilteringSelect? does. The version is 1.0.0 using AOL's url.

And yes getValue() is depreciated but using attr('value') would return the same inconsistencies. I have attached a html file displaying this behavior. The datastore looks like this: {"identifier": "pk", "label": "name", "items":[{'pk': 'AK', 'name': 'Alaska'}]}.

Because I was unsure as to whether or not setting the value in the inline declaration (or setting it programmatically) would affect the result, you have to select each result manually, the same way the typical user would select their options in a form.

Thanks,

-Heather

Attachments (1)

GetValuesTest.html (7.9 KB) - added by heatherk 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by heatherk

Attachment: GetValuesTest.html added

comment:1 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3
Resolution: invalid
Status: newclosed

ComboBox? always returns the displayed value by design. FilteringSelect? can be programmed to return different hidden values. That's the difference between the widgets.

comment:2 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.