Opened 11 years ago

Closed 7 years ago

#7943 closed enhancement (invalid)

Can't load doh.robot "remotely".

Reported by: Joseph Scheuhammer Owned by: Joseph Scheuhammer
Priority: high Milestone: future
Component: TestFramework Version: 1.2.0
Keywords: Cc: Douglas Hays, James Burke
Blocked By: Blocking:

Description

Suppose one wants to use the dojo.robot, but doesn't want to maintain a local copy of the code. This is similar to getting the dojo core from a remote site, for example:

<script type="text/javascript" djconfig="isDebug: true, parseOnLoad: true"
	src="http://o.aolcdn.com/dojo/1.2.0/dojo/dojo.xd.js">
</script>

Adding the following should be sufficient to load dojo.robot:

<script type="text/javascript">
	dojo.require("dojo.robot");
</script>

However, while the above does load dojo core and dojo.robot, it fails to acquire the base doh.robot object. Inspecting the HTML in firebug reveals the following generated script elements:

<script type="text/javascript" djconfig="isDebug: true, parseOnLoad: true"
	src="http://o.aolcdn.com/dojo/1.2.0/dojo/dojo.xd.js">
</script>
<script type="text/javascript"
	src="http://o.aolcdn.com/dojo/1.2.0/dojo/robot.xd.js">
</script>
<script type="text/javascript"
	src="http://o.aolcdn.com/dojo/1.2.0/dojo/../util/doh/robot.xd.js">
</script>

The failure occurs at the last script tag -- its src url is invalid. (Not sure what it should be...)

The attached file, "RemoteRobot.html", is a way to test the above (tested with FF3/MacOSX).

Attachments (1)

RemoteRobot.html (516 bytes) - added by Joseph Scheuhammer 11 years ago.

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by Joseph Scheuhammer

Attachment: RemoteRobot.html added

comment:1 Changed 11 years ago by Joseph Scheuhammer

Cc: Douglas Hays added
Owner: changed from alex to haysmark

comment:2 Changed 11 years ago by Adam Peller

Cc: James Burke added

comment:4 Changed 11 years ago by James Burke

Owner: changed from alex to James Burke

comment:5 Changed 11 years ago by James Burke

Resolution: invalid
Status: newclosed

The CDN builds are optimized for using the toolkit in browser applications, and not providing all of the toolkit from the CDN. For instance, the tests directories are not shipped to CDN builds. Some of the dojox tests may be slipping through due to a bug in the build process, but once that is fixed, no tests will be delivered. So marking this as invalid/unsupported.

If this fails with your own custom xdomain build that includes all the tests and robot files, then feel free to reopen.

comment:6 in reply to:  5 Changed 11 years ago by Joseph Scheuhammer

Replying to jburke:

The CDN builds are optimized for using the toolkit in browser applications, and not providing all of the toolkit from the CDN. For instance, the tests directories are not shipped to CDN builds.

To be clear, the issue has nothing to do with the distribution of test files. The issue is that the base doh.robot functionality is missing.

If the policy is that the robot is not supported by the CDN distribution, well, so be it. But, in fact, CDN is serving a broken robot -- it does provide dojo.robot and dijit.robot; and even their experimental counterparts.

That's pointless if the base object, doh.robot, is absent.

comment:7 Changed 11 years ago by dante

@clown - good catch. The dijit.robot and dojo.robot .js files are accidentally ignored in the test cleanup script, and likely should be removed as part of the CDN release steps as they are useless (as you point out) without a full DOH suite as well. Not sure where do document this tidbit, but it would be trivial to remove them as part of the release script. The policy (afaik) is that DOH not be CDN'd, along with the other UI tests (test_*). We're removing them in a semi-automated fashion, but being careful about .js files (the dijit.robot etc are all in the code namespace, which is why they are missed).

Should we reopen this and reassign to me to make the cleanup script slightly more aggressive?

comment:8 Changed 11 years ago by davidb

Resolution: invalid
Status: closedreopened

Before this ticket is closed, maybe we should open a ticket to include a dojo-dev version on CDN? It might encourage the use of the doh robot which is probably a good thing.

comment:9 Changed 11 years ago by Adam Peller

hang on. it seems that by design, tools aren't on the cdn. the fact that robot got into the dojo.* space without thorough review may have been a mistake, not a feature.

comment:10 Changed 11 years ago by dante

Milestone: tbdfuture

enhancement. what exactly are we looking for here? can we take it dojo-contributors?

comment:11 Changed 8 years ago by ben hockey

Owner: changed from James Burke to Joseph Scheuhammer
Status: reopenedpending

the current build strips the robot files from dojo and dijit. is there any other reason to keep this ticket open?

if there's no response this ticket will automatically close in 14 days.

comment:12 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.