Opened 11 years ago

Closed 9 years ago

#7927 closed defect (fixed)

Browser locks up if no height/width is specified on chart

Reported by: ptwobrussell Owned by: Eugene Lazutkin
Priority: high Milestone: 1.5
Component: Charting Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

I noticed that if I don't specify a height/width for a chart and try to create it that my broswer (FF3) locks up. Not the greatest user experience, and probably something that would trip someone up - especially someone new to charting. Maybe we could have a reasonable default included so that this doesn't ahappen.

I didn't dig too much into the root cause, but I assume there's some calculation going on that is depending on a height or width for termination of a loop or something along those lines

Change History (7)

comment:1 Changed 11 years ago by Eugene Lazutkin

Width and height have to specified somewhere. What is your proposal for that?

comment:2 Changed 11 years ago by ptwobrussell

All I'm saying is that it's not a great experience if you're new to the charting widgets and your browser gets locked up because you didn't specify them, whether it's accidentally or because you're a new user and just trying to learn the ropes. Why not have a default built-in, say 500x350 or something like that so that this doesn't happen.

comment:3 Changed 10 years ago by Eugene Lazutkin

Milestone: tbdfuture

Moving open tickets to the future.

comment:4 Changed 10 years ago by Eugene Lazutkin

Milestone: future1.4
Status: newassigned

comment:5 Changed 10 years ago by Eugene Lazutkin

Summary: Browser locks up if no height/width is specific on chartBrowser locks up if no height/width is specified on chart

comment:6 Changed 10 years ago by Eugene Lazutkin

Milestone: 1.41.5

bumping tickets that didn't make the 1.4 cut, but most likely to go in the next point release.

comment:7 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [21712]) Adding reasonable defaults to chart dimensions, !strict, fixes #7927.

Note: See TracTickets for help on using tickets.