Opened 11 years ago

Closed 11 years ago

#7893 closed defect (fixed)

missing separator between releaseDir and releaseName

Reported by: Mike Wilson Owned by: James Burke
Priority: high Milestone: 1.3
Component: BuildSystem Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

When specifying the following for a build:

build.bat
  profile=base  action=clean,release 
  releaseDir=../../release  releaseName=mydojo

the resulting directory will become

../../releasemydojo

and not the desired

../../release/mydojo

The cause seems to be in buildUtil.js:197:

kwArgs.releaseDir += kwArgs["releaseName"];

where the two parameters are joined without a slash.

Change History (2)

comment:1 Changed 11 years ago by James Burke

Milestone: tbd1.3

comment:2 Changed 11 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [15490]) Fixes #7893. Makes sure releaseDir ends in a directory separatotor.

Note: See TracTickets for help on using tickets.