Opened 11 years ago

Closed 11 years ago

#7881 closed defect (worksforme)

Major issue on FF3 Linux - dojo.fx has lint errors that causes TypeError and

Reported by: Pete Smith Owned by: James Burke
Priority: high Milestone: 1.3
Component: fx Version: 1.2.0
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description

fired up FF3 on linux fedora 9, and immediately got errors in Firebug regarding dojo.fx. I ran it through lint, and fixed it - but it complains about unneeded () down low - but it works. Attaching fix.

Attachments (1)

fixed_dojo.fx.js (11.1 KB) - added by Pete Smith 11 years ago.
linted and fixed

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by Pete Smith

Attachment: fixed_dojo.fx.js added

linted and fixed

comment:1 Changed 11 years ago by dante

Owner: changed from Bryan Forbes to dante

are the lint errors causing it to die totally?

could you attach the patch as a .diff against trunk? there is no telling what all needed changed, and its much safer/easier to review.

comment:2 Changed 11 years ago by Pete Smith

well this maybe worse than I thought - it appears that the _base files are not getting included and loaded in time,

failed loading js/dojo-1.2.0/dojo/./fx.js with error: TypeError?: dojo.extend is not a function

if I manually copy in the dojo.extend, it starts tripping on dojo.declare. if I paste that in, it starts complaining about d.boxmodel in sniff. It really doesn't work at all in FF3. If I refresh a few times with the cache on sometimes it all loads in , but if I clear cache out it dies again.

comment:3 Changed 11 years ago by Pete Smith

I have it working by hard coding the dojo.requires:

<script type="text/javascript" src="js/dojo-1.2.0/dojo/dojo.js"></script>
<script>
dojo.require("dojo._base.lang");
dojo.require("dojo._base.declare");
dojo.require("dojo._base.connect");
dojo.require("dojo._base.Deferred");
dojo.require("dojo._base.json");
dojo.require("dojo._base.array");
dojo.require("dojo._base.Color");
dojo.requireIf(dojo.isBrowser, "dojo._base.browser");
</script>
<script type="text/javascript">
dojo.registerModulePath("gq", "../../gq");
</script>

comment:4 Changed 11 years ago by James Burke

Owner: changed from dante to James Burke

Just want to confirm: are you loading dojo from a web server, and not from local disk? Firefox 3 has newer file:// restrictions that might cause loading to fail.

comment:5 Changed 11 years ago by Pete Smith

I am loading from a regular web server on my local system via http. I was having issues loading the en-us bundle before 1.2.0, but now the whole thing crashes because of something to do with loading order. My dev env is hosed unless I hard code those requires as above. This only affects my dev env, since the built one plops all of these in my layer, it doesn't break.

comment:6 Changed 11 years ago by Adam Peller

Cc: Adam Peller added

comment:7 Changed 11 years ago by James Burke

Milestone: tbd1.3
Priority: highestnormal
severity: blockernormal

I finally got my linux server back and running. I am trying on Ubuntu 8.04 with Firefox 3.0.3. I was not able to get an error using the following pages: http://jburke.dojotoolkit.org/dojo-release-1.2.0-src/dijit/themes/themeTester.html

That page loads dojo.fx as well as lots of other things. The above link is a source build. I also tried this link, the result of a standard build: http://download.dojotoolkit.org/release-1.2.0/dojo-release-1.2.0/dijit/themes/themeTester.html

Both seemed fine on my box. I wonder if this is another symptom of the FF3 DOMContentLoaded bug: https://bugzilla.mozilla.org/show_bug.cgi?id=444322

Maybe you can post a public test page or something that I can try from my box.

comment:8 Changed 11 years ago by James Burke

Resolution: worksforme
Status: newclosed

Closing this for now, but feel free to reopen it with a specific test page though.

Note: See TracTickets for help on using tickets.