Opened 11 years ago

Closed 10 years ago

#7878 closed defect (fixed)

Editor table plugin DOA in IE7

Reported by: haysmark Owned by: Mike Wilcox
Priority: high Milestone: 1.3
Component: Dojox Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

http://archive.dojotoolkit.org/nightly/checkout/dojox/editor/tests/editorTablePlugs.html

Load the page in IE7. Before the editor renders you get the error: "this.editorDomNode has no properties." The parser continues to load the Editor widget but without the table controls at the top.

The debugger points to these lines in dojox/editor/plugins/TablePlugins.js:

// IE ONLY
this.editorDomNode.ondragstart = dojo.hitch(this, "onDragStart");
this.editorDomNode.ondragend = dojo.hitch(this, "onDragEnd");

It's odd that "IE ONLY" code would fail in IE.

Change History (7)

comment:1 Changed 11 years ago by Adam Peller

Component: EditorDojox
Milestone: tbd1.3
Owner: changed from liucougar to Mike Wilcox

comment:2 Changed 10 years ago by Mike Wilcox

Milestone: 1.3tbd

I really can't do anything with the table plugins until I hear something about the new editor.

comment:3 Changed 10 years ago by Adam Peller

Mike, I think the assumption should be that there is no new editor until you hear otherwise. How can we make what is in trunk functional?

comment:4 Changed 10 years ago by Mike Wilcox

Part of the problem between the two is how they handle focus, the first being iframe based, the second being div based. I think more of the issue is when I first made it, FF only supported iframe based editors. But then it was IE that threw the errors; go figure.

The more pertinent problem is with work I currently have no bandwidth, and what little I have I tend to lean toward the FileUploader?. I will certainly tackle this when I get time, but I'd rather make it future leaning toward the new editor than toward the old.

comment:5 Changed 10 years ago by bill

Milestone: tbdfuture

comment:6 Changed 10 years ago by Adam Peller

Milestone: future1.3

not so fast (please note priority setting of 'high') there is broken code in the trunk. let's figure out why it's broken before we defer, or whether it should be removed/doc'd.

comment:7 Changed 10 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

Fixed with r16351

Fixes #1778 - did a better targeting of the iframe or editNode - even though they are the same thing, the browsers are funky about it. Everything seems to work pretty well in IE and FF, with the exception of cell color in IE completely fails. Over all good results though. Note to self: this plugin works with iframe-based editors only.

Note: See TracTickets for help on using tickets.