Opened 11 years ago

Closed 10 years ago

#7875 closed defect (fixed)

djConfig.require does not use multiversion scope name

Reported by: James Burke Owned by: James Burke
Priority: high Milestone: 1.3
Component: Core Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

The issue is reported in this forum thread: http://www.dojotoolkit.org/forum/dojo-core-dojo-0-9/dojo-core-support/having-djconfig-require-set-alongwith-djconfig-scopemap-c

Need to use dojo._scopeName or rethink the dojo.forEach call used for djConfig.require.

Change History (1)

comment:1 Changed 10 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [16086]) Fixes #7875, make sure djConfig.require path uses multiversion scope name. This approach also works better in non-eval friendly envs like AIR.

Note: See TracTickets for help on using tickets.