Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#7860 closed defect (duplicate)

DateTextBox in version 1.2RC2 not working properly on FF3

Reported by: ronaldsirius Owned by: Douglas Hays
Priority: high Milestone: future
Component: Dijit - Form Version: 1.2.0
Keywords: DateTextBox FF3 Cc:
Blocked By: Blocking:

Description

I posted this first on the forum and got replies from people who have similar problems. Below is the description of the bug:

When I use a DateTextBox? under FF3 and use the popup calendar to select a value the value is not displayed in the text area after selecting it. Under IE it works fine, anyone have experience with this?

Submitted by jcdecker on Mon, 10/13/2008 - 15:02.

I just noticed this myself. Another problem I've notice is that, if there is an initial value for the date, it doesn't show up, in either FF or IE. In FF, I can see the value, then it disappears.

Change History (6)

comment:1 Changed 11 years ago by Adam Peller

Component: GeneralDijit
Owner: changed from anonymous to Douglas Hays

comment:2 Changed 11 years ago by Douglas Hays

Milestone: tbdfuture

I tried FF 3.0.3 on Win XP Pro (sp3) running: http://download.dojotoolkit.org/release-1.2.0/dojo-release-1.2.0/dijit/tests/form/test_DateTextBox.html and it works fine. I'm deferring this for now to see if anyone can come up with a reliable recreate scenario, or perhaps a patch from someone who can recreate it.

comment:3 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

we can't defer non-reproducible bugs to the future bucket. please reopen with details if this can be reproduced. thanks.

comment:4 Changed 10 years ago by AMe

Resolution: worksforme
Status: closedreopened

Hello, I've the same problem and I noticed that this happens because of iframe/frame, so if dijit DateTextBox? element is used within an ifrem it doesn't bring selected value back to field in Firefox. If iframe content(url) is opened as stand alone in separate browser's window then the DateTextBox? works fine. BR, Arturs

comment:5 Changed 10 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Dup of #7979 (although this ticket came first). Fixed yesterday.

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.