Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#7848 closed defect (fixed)

Dojox Grid columns not resizable when columnReordering="true" on a themed page

Reported by: rlamarch Owned by: Nathan Toone
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.2.0
Keywords: grid, column resize Cc: rlamarch@…
Blocked By: Blocking:

Description

To reproduce this issue, simply modify test_grid_column_reorder.html by changing the body tag from <body> to <body class="tundra">. The columns remain reorderable but if you tried to resize a column, you can't get the cursor to change to the resize handle when hovering between columns. Issue is the same with the soria theme. Tested in Firefox 3.

Change History (8)

comment:1 Changed 11 years ago by Nathan Toone

Owner: changed from Bryan Forbes to Nathan Toone

Reassigning to me

comment:2 Changed 11 years ago by Nathan Toone

Milestone: tbd1.3

comment:3 Changed 11 years ago by Nathan Toone

Milestone: 1.3future

comment:4 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

I think this was the same as #8807

comment:5 Changed 10 years ago by jfirebau

Resolution: duplicate
Status: closedreopened

This bug has either been regressed or never fixed. You can still change the Grid styling to "tundra" and you will not get resize grapples for column resizing. I followed the simple recreate steps in the defect description to confirm on 1.3 -- but I have also confirmed it exists in my projects code as well.

I would really love to see this bug fixed as well as the inclusion of the additional styling that can be seen in the default table look and feel-- that is the cool insert column arrows and red line that can be seen when you reorder columns.

The Tundra styling which I thought was the most popular seems to be lagging behind in grid styling updates.

comment:6 Changed 10 years ago by Nathan Toone

The arrows and red line *do* exist under tundra (the line is blue instead of red).

I am working on fixing the missing hover-over change.

comment:7 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: reopenedclosed

(In [17497]) Fixes #7848 fix cursor and hover styling while dragging columns !strict

comment:8 Changed 10 years ago by Adam Peller

Milestone: future1.4
Note: See TracTickets for help on using tickets.