Opened 11 years ago

Closed 7 years ago

#7844 closed defect (wontfix)

dojo.back not functional in IE8

Reported by: btipling Owned by: Ben Lowery
Priority: high Milestone: future
Component: Version: 1.2.0
Keywords: Cc: Ben Lowery
Blocked By: Blocking:

Description

Not sure what the cause is. Have not tested in other versions of IE, works in Safari 3.1.2, latest nightly of Webkit (r37469), Camino, and FF3.

Change History (13)

comment:1 Changed 11 years ago by James Burke

Milestone: tbd1.3

IE 8 introduces a new hash change function we should be using. Not sure it helps in non-hashing changing back scenarios, but something we need to look at. Marking it for 1.3, since we are hoping to get all IE8 compatibility in for 1.3.

comment:2 Changed 11 years ago by Adam Peller

see #7925

comment:3 Changed 11 years ago by Adam Peller

Cc: Ben Lowery added

dojo.hash code will not be ready for 1.3. Still need a fix. Does anyone know if this is still an issue in the latest IE8 builds?

comment:4 Changed 11 years ago by Adam Peller

Owner: changed from anonymous to Ben Lowery

comment:5 Changed 11 years ago by Douglas Hays

I tested
dojo/tests/back.html
with IE8 public rc1 and everything seems to be working for me. I was able to click all the test buttons and then navigate using the browser's back and forward buttons successfully, but maybe I didn't understand exactly what was broken.

comment:6 Changed 11 years ago by dante

Milestone: 1.31.4

we'll want to ensure this works, and also include onhashchange considerations.

comment:7 Changed 10 years ago by Phil DeJarnett

I was having problems with this myself, so I did some testing. dojo.back() apparently only has problems when IE8 is in IE8/IE8 Standards mode.

dojo/tests/back.html loads in IE8/IE8 Quirks mode (apparently it has no DOCTYPE). If you switch IE8 to standards mode (explained below), then dojo.back becomes flaky at best. Sometimes it loads the data with no back/forward notation, sometimes it works, but appears to load the incorrect data.

For now, I've added "X-UA-Compatible: IE=7" to my application, even though some things work better in IE8, because dojo.back is critical to my application.

Note on changing IE modes: Hit F12 (or Tools > Developer Tools) to bring up the dev tools. Then you can specify the Browser Mode and Document Mode manually, located just to the right of the dev tools menu.

comment:8 Changed 10 years ago by doncorley

I only had a problem with IE8 back functionality when I exited the site, then returned. For example, load the dojo.back example: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojo/tests/back.html Next, click 'Link 3' then 'Link 4' Now, exit the site by entering a new url such as www.google.com Press browser back (correctly displays url#link4) Press browser back again (DOES NOT display the previous link - should be url#link3, is url#link4)

comment:9 in reply to:  description Changed 10 years ago by doncorley

Try adding a DOCTYPE like:
<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 StrictEN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
or
<!DOCTYPE html PUBLIC "-
W3CDTD HTML 4.01 TransitionalEN" "http://www.w3.org/TR/html4/loose.dtd">
to the start of the back example at: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojo/tests/back.html
and the back button behavior gets weird. Try clicking a few of the links. The first back works, then the next back does not.

comment:10 Changed 10 years ago by dante

Milestone: 1.41.5

comment:11 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:12 Changed 9 years ago by bill

Milestone: 1.6future

(sadly) punting seemingly abandoned ticket and meta tickets to future

comment:13 Changed 7 years ago by bill

Component: General
Resolution: wontfix
Status: newclosed

dojo.back is deprecated by dojo.hash

Note: See TracTickets for help on using tickets.