Opened 11 years ago

Closed 11 years ago

#7839 closed defect (fixed)

Tabs with doLayout = false causes funny jumping on IE

Reported by: Pete Smith Owned by: Douglas Hays
Priority: high Milestone: 1.2.1
Component: Dijit Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

In IE6, FF3, or IE7, if you put

<div id="mainTabContainer" dojoType="dijit.layout.TabContainer?" doLayout="false">

LOW in the PAGE and click tabs, you get this funny jump effect, and the tab does not open. If you click the tab again, it works. This works fine in FF2 on linux.

Attachments (1)

test_TabContainer_noLayout.html (11.6 KB) - added by Pete Smith 11 years ago.
IN IE (and I have seen FF3) tabs bounce.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Pete Smith

IN IE (and I have seen FF3) tabs bounce.

comment:1 Changed 11 years ago by Pete Smith

after pounding this all day - dijit.form._FormWidget adds a new _onFocus method line 93

_onFocus: function(e){
		dijit.scrollIntoView(this.domNode);
		this.inherited(arguments);
	}

if you comment out the dijit.scrollIntoView - it works as it did before. 1.1.1 did not have this _onFocus.

comment:2 Changed 11 years ago by Adam Peller

Milestone: tbd1.2.1
Owner: set to Douglas Hays

see [13752]

comment:3 Changed 11 years ago by Douglas Hays

When a form widget is off the screen and then is focused, it scrolls into view. I think the problem that needs to be fixed somehow is that the tab does not open because the scrolling happens on the mousedown event but the tab changing happens on the mouseup event, but now the tab has changed positions and no longer receives a mouseup.

comment:4 Changed 11 years ago by Adam Peller

due to the regression, we should rollback the change, reopen #6215 and fix in 1.3.

comment:5 Changed 11 years ago by Douglas Hays

[15498] Fixes #7839 in 1.2.1. Adds internal _scroll attribute to form widgets so that scrollIntoView can be optionally disabled. Intended as a regression patch.
Leaving open awaiting a fix in trunk (may decide to make the scroll attribute public).

comment:6 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

[15514] Fixes #7839 in trunk. Add public scrollOnFocus attribute (default true) for form widgets to control if scrollIntoView is called from the focus handler.

Note: See TracTickets for help on using tickets.