Opened 11 years ago

Closed 11 years ago

#7837 closed defect (fixed)

dojox.image.Slideshow won't play in 1.2 unless autoStart set to true

Reported by: rchriste70 Owned by: dante
Priority: high Milestone: 1.3
Component: Dojox Version: 1.2.0
Keywords: slideshow Cc:
Blocked By: Blocking:

Description

Trying to port my app to the 1.2.0 release of Dojo and have found that the slideshow won't play unless I set the autoStart attribute to true. And even then, if I pause the slideshow, it won't start up again. Any ideas?

The tests on the nightly build don't seem to work either... http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/image/tests/test_SlideShow.html

I've experienced this issue on FF2, IE6/7 and even Google Chrome. I'm running an XP box.

Attachments (1)

SlideShow_Slideshow.patch (531 bytes) - added by Shane O'Sullivan 11 years ago.
patch to fix this issue. Thanks to Robert for diagnosing the problem and fix

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by rchriste70

In further analysis, it looks as if in the toggleSlideShow function, the following if statement's second term is undefined:

if(this.images[this.imageIndex] && this.images[this.imageIndex].complete)

Modifying the if statement to call the isImageLoaded for the specified imageIndex seems to resolve the issue properly:

if(this.images[this.imageIndex] && this.isImageLoaded(this.imageIndex))

My two cents...

comment:2 Changed 11 years ago by rchriste70

I believe this is caused by the complete property only being valid on img elements, and it seems that the img has been moved into a div, which is stored in the images[].

So the other solution is to reference the stored img element within the div, in which case the aforementioned if statement might look like the following:

if(this.images[this.imageIndex] && this.images[this.imageIndex]._img.complete){

compared to the current

if(this.images[this.imageIndex] && this.images[this.imageIndex].complete){

Regards,

-Robert

comment:3 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to dante

Changed 11 years ago by Shane O'Sullivan

Attachment: SlideShow_Slideshow.patch added

patch to fix this issue. Thanks to Robert for diagnosing the problem and fix

comment:4 Changed 11 years ago by dante

Milestone: tbd1.3
Resolution: fixed
Status: newclosed

fixed in [15440]

Note: See TracTickets for help on using tickets.