Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#7836 closed defect (worksforme)

dijit.form.Textarea won't get focus unless you click at the very first line

Reported by: pompiuses Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

I'm using dojo-mini-1.1.1 on Windows XP Professional.

Problem with dijit.form.Textarea: If you don't click at the very first line, it doesn't get focus.

Happens in IE6 and IE7.

Change History (3)

comment:1 Changed 11 years ago by bill

Owner: set to Douglas Hays

Hmm, that doesn't sound good. Is this reproducing for you on http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Textarea.html ?

On there it gets focus for me when clicking on the bottom Textarea (that starts with "this is a textarea with a LOT of content"), although I see another problem that the screen jumps.

comment:2 Changed 11 years ago by Douglas Hays

Milestone: tbd1.3
Resolution: worksforme
Status: newclosed

I unzipped http://download.dojotoolkit.org/release-1.1.1/dojo-release-1.1.1-mini.tar.gz and copied over dijit/tests/form/test_Textarea.html from a regular dojo 1.1.1 build and it works for me on IE6. I tried the textarea outlined in red, entered a lot of blank lines, blurred out, then clicked back in at the bottom of the textarea.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.