Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7826 closed defect (fixed)

[regression] NumberTextBox invalid values being submitted as NaN

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.2.1
Component: Dijit - Form Version: 1.2beta
Keywords: Cc: Nathan Toone
Blocked By: Blocking:

Description

Starting with 1.2, blank NumberTextBox? form values submit as "NaN". It should be "" (blank) as in 1.1.1.

Attachments (1)

7826_12x.patch (1.4 KB) - added by Douglas Hays 11 years ago.
overwrite serialize method and don't filter form reset value

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by Douglas Hays

Attachment: 7826_12x.patch added

overwrite serialize method and don't filter form reset value

comment:1 Changed 11 years ago by Douglas Hays

Run test_validate.html, press "View data" button at the bottom and you can see that the "fav" box is submitting "NaN". It should be blank. This is a regression from 1.1.1.

comment:2 Changed 11 years ago by Douglas Hays

Cc: Nathan Toone added

toonetown, can you review this patch since bill is away?

comment:3 Changed 11 years ago by Nathan Toone

Looks OK to me - the only question I would have is the need to change the postCreate for TextBox? (though it looks like an OK change to make...)

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

[15507] References #7826 for 1.2.1. Add serialize method to NumberTextBox? to always send a blank for invalid values. [15508] Fixes #7826 in trunk. Add serialize method to NumberTextBox? to always send a blank on form submit for invalid values.

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.