Opened 13 years ago

Closed 12 years ago

#782 closed defect (duplicate)

Combox is missing setKeyValue() function

Reported by: joose@… Owned by: haysmark
Priority: high Milestone: 0.9
Component: Widgets Version: 0.3
Keywords: Combobox Cc: joose@…
Blocked By: Blocking:

Description

Setting combobox value according to key is not currently possible. setting value to widget should be possible to do with key or with string. Mainly because you could have combobox where you can add data too, so setValue(name) is needed there and setKeyValue(key) should be available too.

Setting combobox value according to key is importanta, if you have your data coming somewhere and you need to set default value.

Example: your data 1,"name 1"],[2, "name 2"?;

dojo.widget.byId('myComboBox').setKeyValue(2); would result showing "name 2" in combobox.

Change History (8)

comment:1 Changed 13 years ago by joose@…

comment:2 Changed 13 years ago by dylan

Component: GeneralWidgets
Owner: changed from anonymous to bill

comment:3 Changed 13 years ago by bill

Milestone: 0.40.5

As discussed on #dojo we'll address comobobox issues in 0.5, maybe making an AutoCompleter? widget (that knows nothing about keys), and possibly turn Combobox into a fancy widget that goes by keys/labels, but can also accept new data.

comment:4 Changed 12 years ago by Douglas Hays

Owner: changed from bill to Douglas Hays

comment:5 Changed 12 years ago by haysmark@…

Autocompleter no longer has keys, so this is now a non-issue.

comment:6 Changed 12 years ago by Douglas Hays

Owner: changed from Douglas Hays to haysmark@…

comment:7 Changed 12 years ago by haysmark

Owner: changed from haysmark@… to haysmark

comment:8 Changed 12 years ago by haysmark

Resolution: duplicate
Status: newclosed

Duplicate of #1673.

Note: See TracTickets for help on using tickets.