Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#7814 closed defect (fixed)

Grid error encountered when sorting with a dojox.grid.cells.Editor open for editing

Reported by: matt5218 Owned by: Bryan Forbes
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

When a cell type: dojox.grid.cells.Editor is open for editing try and sort a column. Causes data to be lost.

To reproduce open cell under 'Message' column and then try and sort or resize column using the following link:

http://download.dojotoolkit.org/current-stable/dojo-release-1.2.0/dojox/grid/tests/test_edit_dijit.html

Change History (7)

comment:1 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.2.1
Summary: Grid loses data when sorting with a Editor open for editingGrid error encountered when sorting with a dojox.grid.cells.Editor open for editing

comment:2 Changed 11 years ago by Adam Peller

Milestone: 1.2.11.2.2

comment:3 Changed 11 years ago by Adam Peller

Milestone: 1.2.21.3

comment:4 Changed 11 years ago by Jared Jurkiewicz

I think this issue is is partially: http://bugs.dojotoolkit.org/ticket/8575

Though my fix I did for 8575 doesn't completely correct for it (It does fix the resize column break, at least). When I sort the editor ends up with ... in it instead of the data of the row. Probably because it captures the cell value of '...' while data is loading and opens the editor before the sort finishes.

comment:5 Changed 11 years ago by Bryan Forbes

Milestone: 1.3future

comment:6 Changed 9 years ago by Evan

Resolution: fixed
Status: newclosed

(In [23620]) Fixes #7814 by saving data in editing before sorting, see also #11386

comment:7 Changed 9 years ago by evan

Milestone: future1.6
Note: See TracTickets for help on using tickets.